![]() |
|
Comments disabled in latest version - Printable Version +- ZenphotoCMS Forum (https://forum.zenphoto.org) +-- Forum: Support (https://forum.zenphoto.org/forum-1.html) +--- Forum: General support (https://forum.zenphoto.org/forum-4.html) +--- Thread: Comments disabled in latest version (/thread-4831.html) Pages:
1
2
|
Comments disabled in latest version - pehansen - 2009-03-10 Hello, I have tried to install latest version of Zenphoto with zenpage.... I have a problem with comments, suddenly after working fine, one or more albums are closed for comments, even though all settings are set to enable comments... Even tried to install from scratch... create new album... everything OK... comments working... then next day upload some new images... and now gallery closed for comments.... even though all settings show the opposite... Comments disabled in latest version - nynexshadow - 2009-03-11 Hi, I seem to have the same issue with zenphoto-2009-03-08-trunk. I have looked into it and if I check the box on the admin section of the album for allow comments then save it for some reason it doesn't save it. I have edited the commentson field of the sql database which has now allowed comments again. Obviously i realise it's not fixing the problem but it's a temp workaround. Comments disabled in latest version - sbillard - 2009-03-12 Thanks, Seems an error has crept into the allow comments form. It will be fixed in tonight's build. Comments disabled in latest version - slaattnes - 2009-10-02 The same error have occured in the two latest builds (4500 and 4505). Comments disabled in latest version - slaattnes - 2009-10-07 And 4516. Comments disabled in latest version - acrylian - 2009-10-07 You really have the comment form plugin activated? Comments disabled in latest version - slaattnes - 2009-10-07 Yes and the check box for aticles are on. Comments disabled in latest version - acrylian - 2009-10-07 You can also set comments on/off for each article/page specifially. Other than that I have no idea as everything works as expected here. Comments disabled in latest version - slaattnes - 2009-10-07 Maybe it have something to do with the renamed pages and news because my site is multilingual, but albums should not be afected. I deleted the whole previous site and put the new build there. The problem is that the "General" tab on album edit (admin-edit.php) isn't showing so there is no way to set comments on or off (btw. souldn't the comments be on by default?) Comments disabled in latest version - acrylian - 2009-10-07 Yes, comments are actually enabled by default. If something is not showing up (I guess you mean the "general" in the right sidebar) something is not installed correctly. The acutal name of a page/article (the titlelink) is not dependend on mutlilingual titles. Comments disabled in latest version - slaattnes - 2009-10-07 Yes I meant the general on the right sidebar. I runned setup.php again. What else are there to install? Maybe there is a mysql issue? Comments disabled in latest version - acrylian - 2009-10-07 I have no idea, never encountered this issue. Any errors in the server log? Comments disabled in latest version - slaattnes - 2009-10-07 No errors in the logs. Which table in the database are responseble for handeling the on/off comments information? This are my tables: zp_options, zp_albums, zp_images, zp_comments, zp_administrators, zp_admintoalbum, zp_tags, zp_obj_to_tag, zp_captcha, zp_zenpage_pages, zp_zenpage_news2cat, zp_zenpage_news_categories, zp_zenpage_news Edit: For now I just set commentson to 1 on the albums in zp_albums Comments disabled in latest version - slaattnes - 2009-10-07 I see now that admin-edit.php is behaving very strangely. When I rename an album and saves, it retuns a blank title and turns comments off... Comments disabled in latest version - slaattnes - 2009-10-08 I have another sugestion; maybe there are conflicting plugins in the newer builds? I'll try to disable them to see if the problem stops. Comments disabled in latest version - slaattnes - 2009-10-08 Last post: I just uploaded the last build (4518) to a different server and with a different database but I have the same problem. Can it then be a browser problem? I've now tried Internet Explorer 8, Opera 10 and Firefox 3.5 so maybe not. URL to testing server: http://folk.ntnu.no/danielto/zenphoto/ and the username and password is admin Do you see the "general" right sidebar acrylian? Comments disabled in latest version - acrylian - 2009-10-08 I did log in for testing and I also did not see the general sidebar. But something must not be right with your installation or the package you downloaded because I see this error in the source code: `Fatal error</b>: Call to undefined function updateThumbPreview() in <b>/web/folk/danielto/zenphoto/zp-core/admin-functions.php</b>` I have never encountered that. Comments disabled in latest version - sbillard - 2009-10-08 Hi. I logged into your test site, enabled the comment_form plugin (which you had said was enabled, but it was not!) Now I can see a comment form on the site. Comments disabled in latest version - slaattnes - 2009-10-08 sbillard: On the test site I didn't enable or disable any plugins to easier find the problem (I didn't say it way enabled - on the original site on the other hand it is enabled.) Anyway the problem is that the general sidebar isn't showing, but thank you:-) acrylian: I can try another build. Which build do you have which are showing the general sidebar? Also, isn't the installation just to run setup.php? I can't see what I could do wrong when installing. Thanks for all the help. Comments disabled in latest version - slaattnes - 2009-10-08 There is no `updateThumbPreview()` in admin-functions.php. Hm... |