Member
Member
telemarknerd   2012-07-14, 23:22
#1
My website was hacked I think because I didn't update zp for a year and a half. I've deleted my albums and zp files off my server and am trying to do a fresh install of the newest version. Every time I get part way through the setup I get stuck at the "about to create tables" part. I get a series of "table creation failures" saying I have an incorrect table name eg.:

Table creation failure:
Query: CREATE TABLE IF NOT EXISTS `Gallery/zenphoto_captcha` ( `id` int(11) UNSIGNED NOT NULL auto_increment, `ptime` int(32) UNSIGNED NOT NULL, `hash` varchar(255) NOT NULL, PRIMARY KEY (`id`) ) CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Error: Incorrect table name 'Gallery/zenphoto_captcha'

Can anyone please help me where to go from here?
Member
Member
sbillard   2012-07-14, 23:32
#2
Your database prefix appears to be "gallery/zenphoto". You need to change that so there is no "/" in the name.
Member
Member
telemarknerd   2012-07-15, 00:30
#3
Thanks sbillard. That solved the problem. I was also wondering in order to disable magic_quotes_gpc, which .htaccess file to add 'php_value magic_quotes_gpc off' in (the file in the zenphoto root folder, or in /zp-data)?. Also, does it matter where in the file the text is inserted?

Many thanks,
Administrator
Administrator
fretzl   2012-07-15, 06:19
#4
Use the .htaccess file in the root folder.
I always put it on top of the file, just before
`<IfModule mod_rewrite.c>`
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.