Running version 1.4.5.7
I've come back to this post twice in the past month, as a solution to some issues I've been having. What led me here was the inabity to change anything about the gallery on the options page. I would try to increase the number of thumbs on the main page or albums. I'd get the green stripe of success, but nothing changed. So I followed the process outlined by sbillard, and it seemed to take care of it, until I had to do it again two or three weeks later.
I just did it again, and not only did it fix the inabiltiy to make changes, it sped up the loading times drastically. There near the end each time before deleting the table, it would take minutes for pages to load. Also I kept getting memory errors, ever few days. I'd up the memory, and that fixed it for awhile, but then it gave the error again. Finally passed 512M memory this morning.
Before I deleted the options table this time, I noticed that there were 848,767 rows in that table. Is that normal? I don't have that many options. Could that be what was slowing down the page loads and explains the ever increasing hunger for memory? After I ran setup again, there were 733 rows.
And finally, can you explain what sbillard meant here when he said: "see if there is a unique key on the options table named "unique_options". It will be unique on the name, ownerid, and theme."
I looked at the table with phpMyAdmin, both from the Browse and Structure views, but don't see anything by that name. There is no field by that name, in the options table, and looking all over the page, I don't see the text anywhere. Where can I see if that key exists?
Well, blah blah blah. Thought I could leave you guys alone here, but apparently there's still room for me to get lost.