I was having this problem as well ...
You probably have something like this in your index.php...
`/* Start Wordpress */
define('WP_USE_THEMES', false);
require($_SERVER["DOCUMENT_ROOT"].'/blog/wp-blog-header.php');
/* Start zenphoto */
require_once("zen/template-functions.php");
$themepath = 'themes';`
Swap them around, i.e. start ZenPhoto first then WordPress.. This worked for me, I was having issues with the image page always displaying a comment error due to some conflict with the $error variable.
This was resolved by replacing all instances of $error in the zen source with $zenerror.
Works perfectly now.