Like @fretzl I cannot reproduce it. I get normal Y-m-d H:i

format here as it is stored in the db itself. The comments admin apge does not even use a specific formatted date but just `date('Y-m-d H:i

', strtotime($date))`.
So it is not even related or affected by the PHP 8.1 `strftime()` deprecation trouble with localized date formats we still have sadly.
Are there any related errors in the debug log? Can you view the database directly and see if there is actually a date stored?
The 1970 date normally only appears if the date is somehow invalid (empty or otherwise wrong).