Member
Member
ctdlg   2026-10-22, 07:46
#1

My Zenphoto site is running on PHP 8.4.26.
Consequently, I am affected by the new PHP security vulnerabilities discovered this week.
While waiting for my hosting provider to update PHP, I have the option to switch to version 8.5.12, which is not affected by these two new vulnerabilities.
Is Zenphoto compatible with PHP 8.5?
Thanks in advance for your clarification!

Administrator
Administrator
acrylian   2026-10-22, 08:34
#2

Zenphoto 1.6.8 should work generally with 8.5 already but there might be some notices here and there. There are fixes for all supported versions:

  • 8.5.12
  • 8.4.27
  • 8.3.36
  • 8.2.35

So it is probably only a matter of time your host will also apply those.
https://www.php.net/archive/2026.php#2026-10-21-5

Member
Member
MarkRH   2026-10-23, 06:40
#3

Heh.. my galleries (v1.5.7) are running on PHP version 7.4.33. Luckily my webhost backported the patch to that version. My other sites are on PHP 8.1.34 which was also patched. My webhost did remove PHP versions 7.2 and 7.3 from their shared servers. In my case they patched PHP without actually changing the version numbers.

I need to work on getting everything to PHP 8.2.X at some point.

Administrator
Administrator
acrylian   2026-10-23, 08:48
#4

Zenphoto 1.5.7 is of course very outdated. Just to mention it again ;-) Yes, most hosts even provided patches to PHP versions that are not officially supported anymore. You should not get to PHP 8.2 because its support ends in about two months. I strongely recommend to update your Zenphoto and switch to 8.4 instead.

This post was last modified: 2026-10-23, 08:50 by acrylian.
Member
Member
ctdlg   2026-10-24, 07:41
#5

Thanks.

Two hours after asking my question here, php patches were applied by my webhost.
I will migrate to PHP 8.5 once it is recommended by the Zenphoto team.

  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.