Pages (2):    1 2
Administrator
Administrator
acrylian   2008-07-21, 08:36
#21
Well, you could simply deinstall the french language locale if you don't need it at all.
Member
Member
cest42   2008-07-21, 11:08
#22
That worked , thanks

Steve
Member
Member
treebonker   2008-08-11, 04:20
#23
It seems I'm not creating the new tables added in 1.17. It's give the same error message for a clean install and upgrading from 1.16. Zenphoto 1.16 installs and works fine. Any pointers?

error msg on setup >>
CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1

The full log file >>
Zenphoto Setup v1.1.7[2013]
Full environment
pass PHP version 4.4.1
pass PHP Safe Mode
pass PHP GD support
pass PHP `glob()` support
pass PHP `gettext()` support
pass PHP `mbstring` package
pass PHP MySQL support
pass [i]zp-config.php[/i] file
pass MySQL setup in [i]zp-config.php[/i]
pass connect to MySQL
pass MySQL version 4.0.22
pass connect to the database `zdatabase`
warn MySQL access rights [unknown] Your MySQL user must have `Create`, `Drop`, `Select`, `Insert`, `Alter`, `Update`, and `Delete` rights.<br/><br/>The [i]SHOW GRANTS[/i] query failed.
pass MySQL [i]show tables[/i] found `zp_administrators`, `zp_admintoalbum`, `zp_albums`, `zp_comments`, `zp_images`, `zp_options`
pass [i].htaccess[/i] file ([i]RewriteEngine[/i] is [b]ON[/b])
pass [i].htaccess[/i] RewriteBase is `/gallery`
pass [i]albums[/i] folder
pass [i]cache[/i] folder
Completed system check
Checked
Begin table creation
MySQL Query ( CREATE TABLE IF NOT EXISTS `zp_tags` (
`id` int(11) UNSIGNED NOT NULL auto_increment,
`name` varchar(255) NOT NULL,
PRIMARY KEY (`id`),
UNIQUE (`name`)
) CHARACTER SET utf8 COLLATE utf8_unicode_ci; ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 6
MySQL Query ( CREATE TABLE IF NOT EXISTS `zp_obj_to_tag` (
`id` int(11) UNSIGNED NOT NULL auto_increment,
`tagid` int(11) UNSIGNED NOT NULL,
`type` tinytext,
`objectid` int(11) UNSIGNED NOT NULL,
PRIMARY KEY (`id`)
) CHARACTER SET utf8 COLLATE utf8_unicode_ci; ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 7
Begin table updates
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `sort_type` varchar(20); ) Failed. Error: Duplicate column name 'sort_type'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `sort_order` int(11); ) Failed. Error: Duplicate column name 'sort_order'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `sort_order` int(11); ) Failed. Error: Duplicate column name 'sort_order'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `height` INT UNSIGNED; ) Failed. Error: Duplicate column name 'height'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `width` INT UNSIGNED; ) Failed. Error: Duplicate column name 'width'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `parentid` int(11) unsigned default NULL; ) Failed. Error: Duplicate column name 'parentid'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `mtime` int(32) default NULL; ) Failed. Error: Duplicate column name 'mtime'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `mtime` int(32) default NULL; ) Failed. Error: Duplicate column name 'mtime'
MySQL Query ( ALTER TABLE `zp_options` DROP `bool`, DROP `description`; ) Failed. Error: Can't DROP 'bool'. Check that column/key exists
MySQL Query ( ALTER TABLE `zp_options` CHANGE `value` `value` text; ) Success.
MySQL Query ( ALTER TABLE `zp_options` DROP INDEX `name`; ) Failed. Error: Can't DROP 'name'. Check that column/key exists
MySQL Query ( ALTER TABLE `zp_options` ADD UNIQUE (`name`); ) Success.
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `commentson` int(1) UNSIGNED NOT NULL default '1'; ) Failed. Error: Duplicate column name 'commentson'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `subalbum_sort_type` varchar(20) default NULL; ) Failed. Error: Duplicate column name 'subalbum_sort_type'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `location` tinytext; ) Failed. Error: Duplicate column name 'location'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `city` tinytext; ) Failed. Error: Duplicate column name 'city'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `state` tinytext; ) Failed. Error: Duplicate column name 'state'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `country` tinytext; ) Failed. Error: Duplicate column name 'country'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `credit` tinytext; ) Failed. Error: Duplicate column name 'credit'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `copyright` tinytext; ) Failed. Error: Duplicate column name 'copyright'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `date` datetime default NULL; ) Failed. Error: Duplicate column name 'date'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFValid` int(1) UNSIGNED default NULL; ) Failed. Error: Duplicate column name 'EXIFValid'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `hitcounter` int(11) UNSIGNED default 0; ) Failed. Error: Duplicate column name 'hitcounter'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFOrientation` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFOrientation'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFMake` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFMake'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFModel` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFModel'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFExposureTime` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFExposureTime'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFFNumber` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFFNumber'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFFocalLength` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFFocalLength'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFFocalLength35mm` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFFocalLength35mm'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFISOSpeedRatings` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFISOSpeedRatings'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFDateTimeOriginal` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFDateTimeOriginal'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFExposureBiasValue` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFExposureBiasValue'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFMeteringMode` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFMeteringMode'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFFlash` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFFlash'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFImageWidth` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFImageWidth'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFImageHeight` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFImageHeight'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFContrast` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFContrast'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFSharpness` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFSharpness'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFSaturation` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFSaturation'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSLatitude` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSLatitude'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSLatitudeRef` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSLatitudeRef'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSLongitude` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSLongitude'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSLongitudeRef` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSLongitudeRef'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSAltitude` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSAltitude'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `EXIFGPSAltitudeRef` varchar(52) default NULL; ) Failed. Error: Duplicate column name 'EXIFGPSAltitudeRef'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `image_sortdirection` int(1) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'image_sortdirection'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `album_sortdirection` int(1) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'album_sortdirection'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `total_value` int(11) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'total_value'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `total_votes` int(11) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'total_votes'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `used_ips` longtext; ) Failed. Error: Duplicate column name 'used_ips'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `password` varchar(255) NOT NULL default ''; ) Failed. Error: Duplicate column name 'password'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `password_hint` text; ) Failed. Error: Duplicate column name 'password_hint'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `hitcounter` int(11) UNSIGNED default 0; ) Failed. Error: Duplicate column name 'hitcounter'
MySQL Query ( ALTER TABLE `zp_comments` ADD COLUMN `type` varchar(52) NOT NULL default 'images'; ) Failed. Error: Duplicate column name 'type'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `total_value` int(11) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'total_value'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `total_votes` int(11) UNSIGNED default '0'; ) Failed. Error: Duplicate column name 'total_votes'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `used_ips` longtext; ) Failed. Error: Duplicate column name 'used_ips'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `custom_data` text default NULL ) Failed. Error: Duplicate column name 'custom_data'
MySQL Query ( ALTER TABLE `zp_images` ADD COLUMN `custom_data` text default NULL ) Failed. Error: Duplicate column name 'custom_data'
MySQL Query ( ALTER TABLE `zp_albums` CHANGE `password` `password` varchar(255) NOT NULL DEFAULT '' ) Success.
MySQL Query ( ALTER TABLE `zp_comments` DROP FOREIGN KEY `zp_comments_ibfk1` ) Success.
MySQL Query ( ALTER TABLE `zp_comments` CHANGE `imageid` `ownerid` int(11) UNSIGNED NOT NULL default '0'; ) Failed. Error: Unknown column 'imageid' in 'zp_comments'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `dynamic` int(1) UNSIGNED default '0' ) Failed. Error: Duplicate column name 'dynamic'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `search_params` text default NULL ) Failed. Error: Duplicate column name 'search_params'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `album_theme` text default NULL ) Failed. Error: Duplicate column name 'album_theme'
MySQL Query ( ALTER TABLE `zp_comments` ADD COLUMN `IP` text default NULL ) Failed. Error: Duplicate column name 'IP'
MySQL Query ( ALTER TABLE `zp_comments` ADD COLUMN `private` int(1) UNSIGNED default 0 ) Failed. Error: Duplicate column name 'private'
MySQL Query ( ALTER TABLE `zp_comments` ADD COLUMN `anon` int(1) UNSIGNED default 0 ) Failed. Error: Duplicate column name 'anon'
MySQL Query ( ALTER TABLE `zp_albums` ADD COLUMN `user` varchar(64) CHARACTER SET utf8 COLLATE utf8_unicode_ci default '' ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci default ''' at line 1
MySQL Query ( ALTER TABLE `zp_tags` CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_tags` CHANGE `name` `name` varchar(255) CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_administrators` CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_administrators` CHANGE `name` `name` TEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'CHARACTER SET utf8 COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_options` ADD COLUMN `ownerid` int(11) UNSIGNED NOT NULL DEFAULT 0 ) Failed. Error: Duplicate column name 'ownerid'
MySQL Query ( ALTER TABLE `zp_options` DROP INDEX `name` ) Success.
MySQL Query ( ALTER TABLE `zp_options` ADD UNIQUE `unique_option` (`name`, `ownerid`) ) Failed. Error: Duplicate key name 'unique_option'
MySQL Query ( ALTER TABLE `zp_options` CHANGE `ownerid` `ownerid` int(11) UNSIGNED NOT NULL DEFAULT 0 ) Success.
MySQL Query ( ALTER TABLE `zp_admintoalbum` CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_obj_to_tag` CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
MySQL Query ( ALTER TABLE `zp_options` CHANGE `name` `name` varchar(255) CHARACTER SET utf8 COLLATE utf8_unicode_ci ) Failed. Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'COLLATE utf8_unicode_ci' at line 1
Done with database creation and update
Previous Release was 2013
Member
Member
sbillard   2008-08-11, 16:54
#24
This was a problem caused by the MySQL documents apparently lying on when some support was implemented. Seems the collate clause is not available until MySQL version 5. We have made a change in the nightly build to test the MySQL level and not use this clause unless you have version 5.0 or greater.

Of course, if the collating sequence is important to you, you will have to change it yourself.
Member
Member
DarrellD   2008-08-12, 01:51
#25
Hey guys.. 1.1.7 is looking good. I was looking at the "User Guide" link now on the front page... the documentation is going great! I love the new Themeing tutorial too! Keep up the great work guys.
Administrator
Administrator
acrylian   2008-08-12, 09:02
#26
The old theming tutorial written by you way back then was the base and inspiration of the new one!
Member
Member
sbillard   2008-08-12, 15:06
#27
I hope you will give the nightly a thorough testing. It will be version 1.2 shortly.
Pages (2):    1 2
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.