I'm having the same issue...
Attempt to login to setup.php but entering the correct user/password (as per $conf['adminuser'] and $conf['adminpass'] in zp-config.php) just takes me back to the login form again without displaying an error. Entering incorrect user/password gives me the error "There was an error logging in.
Check your username and password and try again."
I'm on a Windows machine with IIS and also have mod_rewrite off ($conf['mod_rewrite'] = false
I see that Somebum was able to login from another machine which I'll try, but shouldn't have to...
Has anyone resolved this without logging in from a different machine?