Member
Member
e_zorglub   2012-02-09, 13:25
#1
Hello

I have used the sitemap extension 1 week ago and everything went ok. Now I have cleared the sitemap cache, and try to build a new sitemap. But it does not work : the admin page remains blank (`/zp-core/zp-extensions/sitemap-extended/sitemap-extended-admin.php?generatesitemaps&number=1`), and no file appear in the cache/sitemap folder.
I have changed nothing but to add an album and some photos .
Does anyone has the same problem ?

Thanks
Erwann

<a>galerie.erwannf.fr</a>
Administrator
Administrator
acrylian   2012-02-09, 15:33
#2
Please look in your server error log for errors and post them here.
Member
Member
e_zorglub   2012-02-09, 19:40
#3
Thank you for your answer, but there is no error related to my site in the Apache log... I am still searching for the cause of this problem, and trys to revert the different extensions to the previous state.
When I try to generate sitemap, I dont get a blank page, but a page with no body.
Administrator
Administrator
acrylian   2012-02-09, 19:59
#4
Not the apache log, the php error log I mean. If you get a blank page there must be some sort of php error. Did you look in the source of that broken page?
Member
Member
e_zorglub   2012-02-10, 10:46
#5
The last error in the php log in the admin part was on the 26th of January.
But I solved the problem : I switched off the option `mod_rewrite` and the sitemap was properly generated. Then I switched on again `mod_rewrite`, and the sitemap got generated also ! I can now purge and generate sitemap with `mod_rewrite` activated. Strange ?!?
Administrator
Administrator
acrylian   2012-02-10, 12:58
#6
Indeed strange. We will try to reproduce this. It should generally work with and without mod rewrite (if your server has that naturally).
Administrator
Administrator
acrylian   2012-02-10, 14:52
#7
I can reproduce it, somehow this broke unnoticed. We will look into this.

Update:
Fix will be in tonight's nightly. It was a problem with dynamic albums that caused a memory overload. At least that is what I saw. Please give it a try.
  
Powered By MyBB, © 2002-2026 MyBB Group.
Made with by Curves UI.