There is a plugin to block access if you fail at loggin in often enough (defined by the plugin.) So if you have enabled this plugin and messed up loggin in you may be blocked for whatever you have set for the timeout. (default is one hour.)
If this is the problem you can turn off that plugin when you visit by the proxy server. However, it seems on the surface that it would not be the cause as for sure the timeout should have expired by now unless you set it to something really long.
Other than this plugin, it is not Zenphoto that is blocking the access.