Quote:At first I had an error message about getTheme being deprecated. But while trying to fix the album problem, I ran setup again and I am no longer getting that error message.
If you rewrote the use of that function then ofcourse the error would go away. But if you did not, then maybe the `deprecated-functions` plugin is now disabled. You would simply get a missing function error which might not be in the Zenphoto logs, only in the CGI error logs.
Quote:The biggest question I had was whether to select MySQLi, MySQL or PDO.
Any one of these will work. Generally if `MySQLi` is available PHP recommendes it over `MySQL`. The SQL warnings you got above were related to running [i]setup[/i] and presumably have gone away now.
The `Authorization cookie` security log was probably also part of running setup and can be ignored.
The `Blocked access` messages come from a user with insufficient priviledges trying to directly access an album/image tab on the back end. As to why you are getting that, there is not sufficient information to know.