I often have "red crosses" during setup process (on Mod_Rewrite check, Theme setup or Plugin setup).
In that case, I have an entry in my debug log:
```
{31677:Fri, 05 Oct 2018 14:53:43 GMT} Zenphoto v1.5
EXCEPTION (0): Call to a member function query() on boolean in /.../public_html/zenphoto__test/zp-core/functions-db-MySQLi.php on line 73
```
Heard about that but I could never really reproduce it.
The line in question refers to this one within that method itself:
`if ($result = @$_zp_DB_connection->query($sql)) {…}` so somehow `$_zp_DB_connection` is not an object but a boolean value (Which the original author expected to happen thus the `@`). That would happen if the db connection is not there for example. Why that happens on your setup I have no idea…
That's as it says some file permission error. Is `zp-data/t\xc3\xa9st.jpg` your test image for special chars?
Anway, Fretzl and I had a conversation about the original error as he gets this on his live host (and only there) occasionally. He could narrow it down to a mysql server limitation of `max_user_connections`. Meaning too many db requests at the time. Certainly setup does a lot especially on the db upgrade sections. Probably time to cleanup all the upgrade stuff for stone age releases by now.
Here is a way described to find out what value your server has set:
https://dba.stackexchange.com/questions/47131/how-to-get-rid-of-maximum-user-connections-error
test image file is called `tést.jpg`
but it seems not to be the right way for this issue and you are probably in the right direction with `max_user_connections`.
as far I can see, `SHOW VARIABLES LIKE 'max_user_connections';`gives me 30 as a result.
I will have a look with my host.
according to me, setup process should take care about this limit and goes slowly if necessary.
i will create a ticket, to not forget.
No need for a ticket. We will try to look into this but setup is not the easiest part of Zenphoto. So it might take a while and not be for 1.5.1 which will be released soon.
too late...
but like that, we (me, you and others) don't forget (a message from the forum sometimes falls into oblivion).
this error corrupts the instal process (openstreetmap plugin and maybe other, do not work well after setup)
maybe this ticket https://github.com/zenphoto/zenphoto/issues/1197 was a tree hiding the forest...
of course, I have a look before writing that.
the wrong setup reset my default layer and there is no markers displayed.
I have to manually set this value to make it work again.