Acrylian, I used the Cachemanager locally for my entire gallery for 8 cache sizes. Worked fine with the max_execution_time set very high. Uploaded 76,000 cache files in about 7 zip files. Only took 1 day of work. I will test cachemanager on my live site, which has the 30 second limit, and see if it generates an error in the php log. I get throttled very quickly so I haven't tested yet.
Thanks