I completely re-uploaded the site from my working NAS copy and am still getting the error (initially I had done a fresh install from the 1.6.1a download)
Here is my error in the error log that I believe is related, but this references a core file I have never altered, so I don't know. Any help is still appreciated:
WARNING: mysqli::query(): (HY000/3685): Illegal argument to a regular expression. in /home/(mydomain)/zp-core/classes/class-dbmysqli.php on line 69
mysqli->query called from dbMySQLi->query (class-dbmysqli.php [69])
from dbMySQLi->queryFullArray (class-dbmysqli.php [114])
from SearchEngine->searchFieldsAndTags (class-searchengine.php [1097])
from SearchEngine->getSearchImages (class-searchengine.php [1590])
from SearchEngine->getImages (class-searchengine.php [1673])
from SearchEngine->getNumImages (class-searchengine.php [1556])
from getNumImages (template-functions.php [2113])
from include (search.php [24])
from include (index.php [128])
from index.php [79]
I can say I have discovered if I only check to search in tags, or if I click a tag link, it will fail. If I search for everything, including tags, it will now work, but it seems to ignore any tag results, but if tags is checked by itself, it fails, or if I click a tag link, it fails.
IE: If I check tags/title/date/description - and search for the term "Aladdin" which is in one description and 30some tags, I'll get one result, even though tags was checked - it ignores the tags. So the search issue seems to be it is ignoring tags altogether, saying that there are no identified tags, even though the tag list populates correctly and the tags noted on each individual picture page (image.php) shows the correct tags for each image.
When I go into the databases for the working and non working sites and look at the tags entries, they all seem to be there for both, formatted the same. IE, the database structure looks the same as far as I can tell. One site working, one site not.