Have you solved this problem? I visited your site and downloaded the image `IconS/0506.png` with no problems.
Anyway, your hosting service has not really looked at the problem. The path the script uses is correct (assuming you have set mod_rewrite). The .htaccess and script files will locate the file in the albums folder and serve it so long as no errors occur. Unless you have relocated your albums folder you should not have to edit your zp-config.php file. If the setup program was happy with it it should work.
For your second problem in the initial post. Does the image show after you refresh the browser? If so, maybe your server is not serving the image quickly enough and the browser is timing out.