ISSUE RESOLVED: I reinstalled and updated to version 1.2.8, and refreshed the database, and that got the gallery back up, but I was getting the an error message "call to undefined function getImageEXIFData() in ...\themes\default\image.php" on every page where the comment section would be. When I did a web search, I discovered several other ZenPhoto sites with the same error, and I discovered that the function had been renamed to getImageMetaData(). I changed "getImageEXIFData()" to "getImageMetaData()" in my image.php file, and that solved the problem, so everything is back to normal. My mistake was that I used my old version of image.php when I updated to 1.2.8 because I had customized the theme.